1
answer

nxlog windows XP - service restart

Hy, I need some help in configuring my nxlog in windows XP.

System:
S.O. -> windows XP
NXLOG Version -> 2.8.1248

LOGS:
We use a log file for each event and these log files are stored in an hierarchical directory as: f:\year\month\day\accxxxx.txt (e.g. f:\2015\09\03\event000001.txt)

nxlog.conf excerpts:

AskedSeptember 3, 2015 - 1:31am
1
answer

Question about dropping syslog messages before they are sent

Hello,

I think this is an easy answer, but I am having some issues.  I am trying to read in a log file and send out a syslog message.  If the line in the file contains the word error, I want a syslog message to be sent.  If the file does not contain that word, just drop the message.  What would be the proper way to do this?  Below is what I currently have.

 

AskedSeptember 2, 2015 - 2:51pm
1
answer

Data size is over the limit

Hi,

I am trying to read multiline xml files (results of ELMAH logs in ASP.NET), but for some of them I am unable to do so, as they contain lots of information. This results in errors like this:

2015-09-02 08:50:50 ERROR data size (119671) is over the limit (65000), will be truncated

I tried googling for a resolution to this problem, but I couldn't find any information anywhere about a data size limit in nxlog. Could some please advise what I could do to fix this?

AskedSeptember 2, 2015 - 1:48pm
1
answer

im_file ; File with lock

Hello,

Recently, i ran into a problem with file locking. One application here is generating some log file, one per client, when nxlog try to read file, i got error :

ERROR failed to open LOGFILEPATH; Le processus ne peut pas accéder au fichier car ce fichier est utilisé par un autre processus.

Initaly my configuration was :

AskedSeptember 2, 2015 - 9:51am
0
answers

Compiling on Solaris 11

Hi ,

I am trying to compile nxlog on solairs 11 sparc platform.

I am encoutering the following errors while compiling.

configure: error: libapr-1 not found

gcc: error: unrecognized command line option '-mt'

I used the following parameters :: ./configure APRCONFIG=/usr/apr/1.3/bin/apr-1-config

Please let me know if any one of you have successfully compiled it on Solaris 11.

Thanking you with regards.

 

 

AskedAugust 31, 2015 - 3:02pm

Pages