1
answer

Identifiing multiline Messages not working

Hi,

i have follwing logentry:

------------- New entry --------------------

line 1

line 2

line 3

line x

{blank line}

------------- New entry --------------------

line 1

line 2

line 3

line x

​{blank line}

 

AskedJuly 13, 2015 - 9:50pm
1
answer

sql_exec arguements

I have the following sql_exec command outline in my config:

<Output out>
    Module      om_odbc
    ConnectionString    DSN=nxlog;
    <Exec>
      sql_exec("INSERT INTO eventlog (hostname) VALUES (?)", '$Hostname');
    </Exec>
</Output>

This is exactly how the 2 examples in the documentation have it set up, I cannot seem to get it to work though I get the following error in my error log:

AskedJuly 13, 2015 - 6:44pm
1
answer

Problems using SSL input with NXLog

TL;DR summary: NXLog won't load my certificate - why?

I've set up an NXlog CE server to act as an encrypted entrypoint for a Graylog server. After creating a self-signed certificate and adding it to the configuration, I get an unexpected error in the log when NXlogs starts up.

AskedJuly 10, 2015 - 9:13am
1
answer

AIX - compile but not run - dynamically linked shared object libraries (.so) not exist

Trying to run nxlog-ce 2.8.1248 on AIX 7.1.

Compilation is succesful, nxlog binnary is created, but can not run. There are messages like:

"ERROR Failed to load module from /usr/local/libexec/nxlog/modules/extension/xm_syslog.so, Could not load module /usr/local/libexec/nxlog/modules/extension/xm_syslog.so.; System error: No such file or directory;DSO load file"

There are static libraries (.a) in directories but dynamic (.so) not.

AskedJuly 7, 2015 - 3:20pm
1
answer

NXlog 2.8.1248 crashing often

Hi,

 

We have deployed nxlog 2.8.1248 for Windows on many computers (so far about 200) using Windows 2008 R2, 2012 and 2012 R2.

it appears we are facing multiple issues randomly:

- Service is crashing expectably and log an error 1067 and after a few attempt, it can restart successfully

- Service doesn't want stat and log error 1053 at each try (uninstall/reinstall of the client doesn't help)

AskedJuly 3, 2015 - 10:57am

Pages