1
answer

No connection could be made because the target machine actively refused it.

Hello,
nxlog was sending to nagios log server just fine for a few days and then all of a sudden we started seeing the below errors in the nxlog.log file that are preventing logs from being sent.

ERROR om_tcp send failed; An existing connection was forcibly closed by the remote host.

ERROR couldn't connect to tcp socket on xx.xx.xxx.xx:3515; No connection could be made because the target machine actively refused it.

AskedJanuary 4, 2016 - 10:33pm
0
answers

om_odbc sql_exec bind parameters

Hello

When I call sql_exec with a bind parameter

if (sql_exec("INSERT INTO Events (Id) VALUES(?)", $ID) == TRUE) {}

I get the following error:

INFO SQLBindParam failed; HY104:1:0:[Microsoft][ODBC SQL Server Driver] Invalid precision value

Same commnad using string concatenatiion works fine:

if (sql_exec("INSERT INTO Events (Id) VALUES(" + $ID +")") == TRUE) {}

Could you help me with it?

AskedJanuary 4, 2016 - 2:35pm
1
answer

Issue with syslog message being sent when it shouldnt.

Hello,

I have the following config file. What i want it to do is not send anything that has the word error in it.

 

<Input watchfile_m_NAME1>
  Module im_file
  File 'LOGLOCATION'
  Exec $Message = $raw_event;
  Exec if $raw_event !~ /ERROR/ drop();
  #Exec $SyslogSeverityValue = 6;
  Exec if file_name() =~ /.*\\(.*)/ $SourceName = $1; 
  #Exec if $raw_event =~ /ERROR/ $SyslogSeverityValue = 3;

 

AskedDecember 28, 2015 - 4:28pm
1
answer

NXlog om_ssl infinite reconnection with a SaaS Log Centralizer

Hi,

We are trying to connect NXLog with Logmatic.io with a SSL connection. The certificate provided by Logmatic is valid and works with Rsyslog, Syslog-NG or Open-SSL.

However, no matter how hard we try to connect NXLog we have no success and not enough debugging information to troubleshoot it ourselves.

Here is our config:


<Output out>

AskedDecember 22, 2015 - 9:45am
1
answer

Sending XML file to Syslog Receiver

I have a fairly simple question regarding sending an XML file to my SysLog Receiver (Nitro box).  Currently, I'm attempting to send this file to my Nitro box, but I'm not actually seeing the Syslog being sent to Nitro.  I have tcpdump watching for the packets being sent and I'm not getting any information across.  I verified that packets were being sent and captured to the Nitro box with a generic Syslog generator.  Here is my current .conf file.

AskedDecember 14, 2015 - 4:23pm

Pages