When installing nxlog- ce, I get problems with dependency for the package.

sudo apt install ./nxlog-ce_3.0.2272_ubuntu_focal_amd64.deb
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Note, selecting 'nxlog-ce' instead of './nxlog-ce_3.0.2272_ubuntu_focal_amd64.deb'
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
nxlog-ce : Depends: libperl5.30 (>= 5.30.0) but it is not installable
Depends: libpython3.8 (>= 3.8.2) but it is not installable
E: Unable to correct problems, you have held broken packages.

I can do a lot of trickery but was wondering if you will create a new upgrade soon?
Pinning Python3.8 is a bit tricky and so is libperl5.30

Mats Tage Axelsson

AskedJune 7, 2022 - 2:11pm

Answer (1)

Hello Mats

Currently, there are three different installation packages for the NXLog CE version 3.0.2272: nxlog-ce_3.0.2272_ubuntu_xenial_amd64.deb, nxlog-ce_3.0.2272_ubuntu_bionic_amd64.deb and nxlog-ce_3.0.2272_ubuntu_focal_amd64.deb
Those builds were tested on the Ubuntu 16.04, 18.04 and 20.04 respectively. I suppose that you took the nxlog-ce_3.0.2272_ubuntu_focal_amd64.deb and installed it on the Ubuntu 22.04 LTS (Jammy Jellyfish) which was released on April 21, 2022. And I think it should work fine on it but since this package wasn't designed for the latest Ubuntu OS version - all kinds of dependency problems are possible.

I'm not sure if we have an ETA on releasing the installation package for the Ubuntu 22.04 but I'll check with the Dev Team and in case they do, I'll post it here.