1
answer

I'm having an alert every time the om_http sends a message to a web service. Has anyone ever experienced this?

LOG:
2015-08-19 16:45:18 INFO connecting to localhost:80
2015-08-19 16:45:18 WARNING http server disconnected while reading the response
2015-08-19 16:45:18 INFO reconnecting in 0 seconds

CONF:
<Output outATM>
    Module              om_http
    URL                 http://localhost:80/modules/AtmProcessorMT/index.php
</Output>

AskedAugust 19, 2015 - 11:43pm

Answer (1)

Yes, I had the same issue.

It depends on the web server closing the connection after some minutes. Try putting an infinite timeout in the keepalive settings.

I had to abandon the http method because I found it unusable for a large traffic.

Angelo.

AnsweredAugust 31, 2015 - 2:12pm

Comments (2)

  • tiago_nascimento's picture

    Thank you Angelo,

    I enabled the keep-alive and warnings stopped, but I realized that the performance is low, i do not know if it's nxlog doing the post or my server responding. I will do some tests.

    September 4, 2015 - 3:04pm
  • adm's picture
    (NXLog)

    om_http sends one HTTP request for each event and waits for the response from the HTTP endpoint. This roundtrip adds a significant latency.

    September 4, 2015 - 3:23pm