1
response

I use nxlog in windows,from the log,I get this question:ERROR SSL error, failed to load ca cert from 'C:\Program Files\nxlog\cert\agent-ca.pem', reason: No such file or directory, no such file, system lib
Then I find I do not have the agent-ca.pem.
And in my environment,my pgsql do not get any data.
below is my config.
<Input in>
Module im_file
File "C:\\Users\\xxx\\Desktop\\log.txt"
<Exec>
if $raw_event =~ /^(\w+ \d+ \S+ \S+) (\S+) (\S+):(.+)$/
{
$timestamp = $1;
$hostname = $2;
$eventname = $3;
$event = $4;
}
</Exec>
</Input>
<Output out>
Module om_odbc
ConnectionString Driver={Devart ODBC Driver for PostgreSQL}; Server=127.0.0.1; \
UID=qytangdbuser; PWD=Cisc0123; Database=qytangdb
SQL "INSERT INTO qytdb_network_log (timestamp, hostname, eventname, event) VALUES (?,?,?,?)",$timestamp,$hostname,$eventname,$event
</Output>
<Route r>
Path in => out
</Route>

AskedJune 6, 2019 - 7:58am

Answer (1)

ERROR SSL error, failed to load ca cert from 'C:\Program Files\nxlog\cert\agent-ca.pem', reason: No such file or directory, no such file, system lib This ERROR message is due to the default nxlog.conf being setup to connect to a Manager. The following section will instruct you on how to change your config if you are not using Manager.

# By default, `LogFile %MYLOGFILE%` is set in log4ensics.conf. This
# allows the log file location to be modified via NXLog Manager. If you
# are not using NXLog Manager, you can instead set `LogFile` below and
# disable the `include` line.
#LogFile %MYLOGFILE%
include %CONFDIR%/log4ensics.conf

As for the PostgreSQL not receiving your data, I would break this up into multiple steps for testing. Add an additional output using om_file maybe to see if you are receiving logs from your im_file Input.
You can also check the nxlog.log file output to see if there are any log entries associated with the database connection.
It may be helpful to check the PostgreSQL logs as well to see if there may be some issue with the INSERT command. This should be passed back to the driver and displayed in your nxlog.log file as well.