0
answers

im_odbc query Orcale 12g sys.aud$ table

Hello, I'm trying to query the oracle sys.aud$ table using the nxlog odbc input module (Oracle 12.1.0.2.0) for new audit-events.
I'm using NXlog and the odbc module 4.3.4308. The Error that NXLog is presenting me is:
ERROR SQLDescribeParam returned zero parameter_size or decimal_digit(999, 0)
---
I'm querying the table as follows:

AskedOctober 2, 2019 - 6:14pm
1
answer

im_odbc - incorrect syntax and ERROR id column not found or its type is unsupported

Hello,

I hope someone can help me. I need to pick application logs from a few MSSQL database tables. 3 of 4 works perfect -there are no issues getting the data, but one table is causing issues.

Below you can see input I am using. As you can see, there is one column name with the Danish character, however, I am not sure if only this is causing trouble. The error I receive is:

AskedApril 9, 2019 - 11:11am
2
answers

NXLog and ODBC

Hi ,

Trying to create an ODBC connect for NXLog to connect to.   NXLog is installed on the same Windows 2012 server as the SQL Server 2008R2 instance.

 

Scenario 1:

32-bit ODBC is setup as a System DSN with a SQL Server account that has DBO access to the desired database

NXLog service is setup to run under the System account.   

 

- I've tried both drivers available on the system ("SQL Server Native Client 10.0"  and "SQL Server")

AskedOctober 11, 2017 - 9:54pm
1
answer

Module im_odbc - how to reset value in "?"

Hi!

I have a problem using module im_odbc. I use sql query to receive some data from sql server. For example, query looks like "SELECT [Name] From [MyTable] WHERE [Id] > ?". In some moment, the "?" has stored incorrect value (I don't know how, but it's bigger then MAX(Id) value in my table) and sinse that moment, query has not return any data. 

AskedOctober 27, 2016 - 12:19pm