1
response

Hello All.

I am new to the forum as well as Linux and NXlog. (triple issue I know)

I am attempting to install NXLog (nxlog-ce-2.11.2190_rhel8.x86_64.rpm) on a CentOS 8 machine. I am using the NXLog user guide (9. REHL & CentOS) for installing the program. When I run the command to install the rpm package below, I receive the following error message. I have been unsuccessful searching the internet for a resolution so I though I would give the forum a try. I would appreciate any help or tip which might steer me in the right direction.

Thanks in advance,
Mark

Problem: conflicting requests
- Nothing provides libdbi >= 0.8.1 needed by nxlog-ce-2.11.2190_rhel8.x86_64

AskedJuly 19, 2021 - 8:18pm

Answer (1)

Sounds like quite the learning experience. Good luck! :)

You will likely need to install the EPEL package.

yum install epel-release

Then you will see the packages.

[root@localhost ~]# yum list | grep libdbi
libdbi.x86_64                                                     0.9.0-14.el8                                      epel         
libdbi-dbd-mysql.x86_64                                           0.9.0-14.el8                                      epel         
libdbi-dbd-pgsql.x86_64                                           0.9.0-14.el8                                      epel         
libdbi-dbd-sqlite.x86_64                                          0.9.0-14.el8                                      epel         
libdbi-devel.x86_64                                               0.9.0-14.el8                                      epel         
libdbi-doc.noarch                                                 0.9.0-14.el8                                      epel         
libdbi-drivers.x86_64                                             0.9.0-14.el8                                      epel         
syslog-ng-libdbi.x86_64                                           3.23.1-2.el8                                      epel