9
responses

Hello,

I am trying to connect through SSL to ship logs but nxlog only attempts to connect through SSLv3, not TLS. Any way to force TLS 1.1 or 1.2 handshakes?

Thank you

AskedFebruary 24, 2015 - 1:56pm

Comments (2)

  • goerlitz's picture

    Hello,

    same problem here. I'm trying to forward log events to logstash with the setup described in http://stackoverflow.com/questions/26789903/using-nxlog-to-ship-logs-in-to-logstash-from-windows-using-om-ssl. However, the logstash log contains this error message: "OpenSSL::SSL::SSLError: Client requested protocol SSLv3 not enabled or not supported". Following lines can be found in nxlog.log:

    2015-02-28 22:16:05 INFO connecting to localhost:5000
    2015-02-28 22:16:05 INFO successfully connected to localhost:5000
    2015-02-28 22:16:05 INFO remote socket was closed during SSL handshake
    2015-02-28 22:16:05 INFO reconnecting in 1 seconds

    Seems like SSLv3 has been disabled in recent Java versions due to the POODLE vulnerability. Hence, I wonder how to ship logs from nxlog with TLS 1.2?

    Thanks

Answers (2)

Unfortunately v2.8.1248 can only use SSLv3. Until the new release fixes this you can either reenable SSLv3 on the other end , i.e. edit java.security or download the NXLog EE trial.

This should be fixed in the latest release (nxlog-ce-2.9.1347)

Comments (5)

  • williamwj's picture

    Thanks. I hadn't seen it because it isn't included in the RPM changelog section and the source files have not been made available on your downloads section. Had no idea I would have to install before reading the changelog.

  • adm's picture
    (NXLog)

    That's not included there because of the following RPM policy:

    The list of changes can be as long as is necessary, but keep in mind that this should be a list of changes for the RPM itself and not for the package. It’s considered bad form to include the ChangeLog of the actual program in the RPM ChangeLog.