3
responses

I am attempimg to get nxlog installed on ubuntu. It appears that libperl5.18 is required but no longer available. Any suggestions?

sudo dpkg -i nxlog-ce_2.9.1504_ubuntu_1404_amd64.deb
[sudo] password for
(Reading database ... 59404 files and directories currently installed.)
Preparing to unpack nxlog-ce_2.9.1504_ubuntu_1404_amd64.deb ...
Unpacking nxlog-ce (2.9.1504) over (2.9.1504) ...
dpkg: dependency problems prevent configuration of nxlog-ce:
 nxlog-ce depends on libperl5.18 (>= 5.18.2); however:
  Package libperl5.18 is not installed.

sudo apt-get install libperl5.18
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package libperl5.18 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Linux ubuntunxlog 4.4.0-21-generic #37-Ubuntu SMP Mon Apr 18 18:33:37 UTC 2016 x86_64 x86_64 x86_64 GNU/Linux

AskedJune 27, 2016 - 9:21pm

Answer (1)

Trusty is the codename for Ubuntu 14.04 and the libper5.18 package is there: http://packages.ubuntu.com/trusty/libperl5.18

Perhaps you are attempting to install it on 16.04.

Comments (2)

  • bobbyclarke663's picture

    14.04 is doing the same thing. Wants libperl5.18 and I am unable to install. Also looking for a number lib* packages which I was able to install on 16.04 with apt-get install -f but not with 14.04

    sudo dpkg-deb -f nxlog-ce_2.9.1504_ubuntu_1404_amd64.deb Depends

    libapr1 (>= 1.4.8-2~), libc6 (>= 2.14), libcap2 (>= 2.10), libdbi1 (>= 0.9.0), libexpat1 (>= 2.0.1), libpcre3, libperl5.18 (>= 5.18.2), libssl1.0.0 (>= 1.0.0), zlib1g (>= 1:1.1.4), adduser, openssl, lsb-base