2
responses

Hello nxlog community, :-)

we're currently in the preparation process of analyzing nxlog as potential logging software for our company and while doing so we were looking for a nxlog community edition that supports our SLES operating systems.

The official download page does not list versions for any SUSE operating system. We know that SLES is supported by the enterprise edition, but for testing purposes we would like to use the community edition to get started.

We've successfully compiled the community edition's source code and installed it on SLES via ...

zypper in gcc apr-devel pcre-devel libopenssl-devel libexpat-devel
./configure
make
make install

... but doing so lacks a lot of other things (which must be taken care of manually) like creating nxlog user and group, assigning its GID, creating config files, systemd units, directories in /usr/local/etc ...

What are we missing? What is the best way to get nxlog-ce installed on SLES 15 SP3?

Thank you in advance.

Best regards

Dennis

AskedAugust 29, 2022 - 7:13pm

Comments (2)

  • DennisG's picture

    Hi Klevin,

    thanks for your reply.

    We've already analyzed the RHEL-rpm on SLES. It's not compatible, since it requires libraries in versions that are not available on SLES 15 SP3, even though we've already installed packages libcryptopp-devel and libcryptopp5_6_5:

    localhost:/tmp # rpm -i nxlog-ce-3.0.2272-1_rhel7.x86_64.rpm 
    error: Failed dependencies:
        apr >= 1.2 is needed by nxlog-ce-3.0.2272-1.x86_64
        libcrypto.so.10()(64bit) is needed by nxlog-ce-3.0.2272-1.x86_64
        libcrypto.so.10(libcrypto.so.10)(64bit) is needed by nxlog-ce-3.0.2272-1.x86_64
        libdbi >= 0.8.1 is needed by nxlog-ce-3.0.2272-1.x86_64
        libdbi.so.0()(64bit) is needed by nxlog-ce-3.0.2272-1.x86_64
        libssl.so.10()(64bit) is needed by nxlog-ce-3.0.2272-1.x86_64
        libssl.so.10(libssl.so.10)(64bit) is needed by nxlog-ce-3.0.2272-1.x86_64
        perl >= 0:5.008005 is needed by nxlog-ce-3.0.2272-1.x86_64
        shadow-utils is needed by nxlog-ce-3.0.2272-1.x86_64
    localhost:/tmp # zypper in ./nxlog-ce-3.0.2272-1_rhel7.x86_64.rpm 
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    
    Problem: nothing provides libcrypto.so.10()(64bit) needed by nxlog-ce-3.0.2272-1.x86_64
     Solution 1: do not install nxlog-ce-3.0.2272-1.x86_64
     Solution 2: break nxlog-ce-3.0.2272-1.x86_64 by ignoring some of its dependencies
    
    Choose from above solutions by number or cancel [1/2/c/d/?] (c):
    

    Best Regards

    Dennis

Answers (0)