6
responses

Hello,

We have Nxlog Enterprise Edition 3.1.1930 to collect log from MSSQL 2014 via im_odbc module, but it return the following error.
"ERROR im_odbc couldn't connect to the database, 28000:2:18456:[Microsoft][ODBC SQL Server Driver][SQL Server]Login failed for user ''. (odbc error code: -1)"

The related configuration as below:

<Input in>
Module im_odbc
ConnectionString DSN=SymantecEndpointSecurityDSN;database=sem5;
SQL SELECT IDX as ID,ALERT_IDX as AlertID, COMPUTER_IDX as ComputerID,SOURCE as SRC,VIRUSNAME_IDX as virusname FROM V_ALERTS WHERE IDX > ?
</Input>

Thanks for any help~

AskedAugust 30, 2018 - 9:48am

Answers (2)

You'll need to provide the authentication details in the Connectionstring (user and password) or configure the DSN on the system with proper authentication settings.

I have defined the DSN in ODBC data source, and the user information is correct .

Comments (4)

  • b0ti's picture
    (NXLog)

    You'll need to make sure that the DSN is available for the account nxlog is running under which is normally SYSTEM. Also note that there is a 64 and 32 bit DSN and driver and the 32 bit version of nxlog will not use the 64 bit driver and DSN.

    Lastly I'd suggest using the latest version as 3.1 is quite old.

  • Sam_wang's picture

    Many thanks for your help,

    Yes , I installed nxlog with administrator , and the nxlog service is running under system account. In the error log of mssql, we can see there is no user name in nxlog request.

    2018-08-31 19:33:20.07 Logon Login failed for user ''. Reason: An attempt to login using SQL authentication failed. Server is configured for Windows authentication only. [CLIENT: 172.24.240.15]

    I don't know why it prompts "server is configured for windows authentication only" , factually the MSSQL is configured with mix mode.